• Welcome to the forum website of the Vincent H.R.D. Owners Club.

    Should you have any questions relating to the Vincent H.R.D. Owners Club, or Vincent H.R.D. motorcycles in general, please contact Graham Smith, Online Forum Webmaster by calling 07977 001 025 or please CLICK HERE.

    You are unrecognised, and therefore, only have VERY restricted access to the many features of this forum website.

    If you have previously registered to use this forum website, you should log in now. CLICK HERE.

    If you have never registered to use this forum website before, please CLICK HERE.

Clutch issue

kurtflys

Well Known and Active Forum Website User
Non-VOC Member
I managed to get my new to me Shadow out yesterday for the first time, and what a first gear=) WOW that's big. Anyway I noticed the clutch started slipping when I got near 50 mph and again if I added a little throttle on a hill. What the heck did I do? Let her set to long? I have not added oil but did check it a few weeks back and it seemed fine, Is there a good schematic of any of the systems on the bike that can be bought ? Also after starting the engine ticked over nice and slowly but after the two mile ride and the clutch issue the rpm's went up to 1500 or 1700 rpm and would not slowdown > Do you think these problems are related?
Thanks
Kurt
Lone Star
 
Last edited:

Holger

Forum Website User
VOC Member
Kurt

almost certainly the result of oil finding its way on to the main clutch shoes. You will need to dismantle the clutch and clean and dry all the fibre linings.

Holger
 

Howard

Well Known and Active Forum Website User
VOC Member
Also after starting the engine ticked over nice and slowly but after the two mile ride and the clutch issue the rpm's went up to 1500 or 1700 rpm and would not slowdown > Do you think these problems are related?
Thanks
Kurt
Lone Star[/QUOTE]

Sticking carb slides or throttle cables ??

H
 

vincenttwin

Well Known and Active Forum Website User
VOC Member
Kurt
Bring it on the Texas British singles ride ,we will have it sorted by the end of the week ,all of us have Vincents. first year you come you can ride anything.
get a new oil seal for behind the clutch PD 25
cheers
Peter Allen
 

kurtflys

Well Known and Active Forum Website User
Non-VOC Member
I got about three table spoons out of the primary case. Could that do it?
 
Last edited:

kurtflys

Well Known and Active Forum Website User
Non-VOC Member
This idle problem started with the clutch issue. Not sure if they are related but hard to believe that two problems happen at the same time within seconds of each other/ Stranger things have happened I guess.
 

mercurycrest

Well Known and Active Forum Website User
VOC Member
I managed to get my new to me Shadow out yesterday for the first time, and what a first gear=) WOW that's big. Anyway I noticed the clutch started slipping when I got near 50 mph and again if I added a little throttle on a hill. What the heck did I do? Let her set to long? I have not added oil but did check it a few weeks back and it seemed fine, Is there a good schematic of any of the systems on the bike that can be bought ? Also after starting the engine ticked over nice and slowly but after the two mile ride and the clutch issue the rpm's went up to 1500 or 1700 rpm and would not slowdown > Do you think these problems are related?
Thanks
Kurt
Lone Star
n

Check the ATD Springs.
Cheers, John
 
Warning! This thread is more than 9yrs ago old.
It's likely that no further discussion is required, in which case we recommend starting a new thread. If however you feel your response is required you can still do so.

Top